Group - Critical - Information Disclosure - SA-CONTRIB-2020-030

Project: GroupVersion: 8.x-1.x-devDate: 2020-July-29Security risk: Critical 15∕25 AC:None/A:None/CI:Some/II:None/E:Theoretical/TD:AllVulnerability: Information DisclosureDescription: This module enables you to hand out permissions on a smaller subset, section or community of your website.
The module used to leverage the node grants system but turned it off in its recent 8.x-1.0 release in favor of a system that works for ALL entity types, not just nodes. By doing so, some regular node access checks turned from neutral into allowed because of the way the node grants system operates.
This vulnerability is mitigated by the fact that an attacker must have the GroupNode plugin installed on their website and have no other hook_node_grants() implementations on their website aside from the one that was recently removed by Group. If you do not use the GroupNode plugin or still have hook_node_grants() implementing modules enabled, your site may not be affected.Solution: Install the latest version:

  • If you are using 8.x-1.0-rc5 you can keep using that version or upgrade to 8.x-1.1
  • If you are using 8.x-1.0 you should upgrade to 8.x-1.1

Reported By: 

Fixed By: 

Coordinated By: 

Path to article https://www.drupal.org/sa-contrib-2020-030