Drupal core - Moderately critical - Multiple vulnerabilities - SA-CORE-2022-015

Project: Drupal coreDate: 2022-July-20Security risk: Moderately critical 11∕25 AC:Complex/A:User/CI:Some/II:Some/E:Theoretical/TD:UncommonVulnerability: Multiple vulnerabilitiesDescription: The Media oEmbed iframe route does not properly validate the iframe domain setting, which allows embeds to be displayed in the context of the primary domain. Under certain circumstances, this could lead to cross-site scripting, leaked cookies, or other vulnerabilities.
This advisory is not covered by Drupal Steward.Solution: Install the latest version:

All versions of Drupal 9 prior to 9.3.x are end-of-life and do not receive security coverage. Note that Drupal 8 has reached its end of life.
Drupal 7 core does not include the Media module and therefore is not affected.Reported By: 

  • Heine of the Drupal Security Team

Fixed By: 

Path to article https://www.drupal.org/sa-core-2022-015